Welcome, Guest
Username: Password: Remember me
Welcome, Amulet Beta Testers!
Here you'll find discussion of the latest Amulet Voice Remote beta software, as it moves towards general release. Please give us your feedback, bug reports, and comments on how you are getting on with beta testing, along with any feature requests you think may help improve the Amulet software.

Please only post here relating to issues with Amulet beta software releases; use the main forums for general discussion about Amulet.
  • Page:
  • 1

TOPIC: My Movies support in Amulet 3.00.01

My Movies support in Amulet 3.00.01 6 years 2 months ago #510

  • eddy
  • eddy's Avatar
  • OFFLINE
  • Administrator
  • Posts: 191
  • Thank you received: 2
  • Karma: 5
Now that the new Amulet beta with My Movies integration has been released, we're keen to hear how well it works for you. My Movies supports many different scenarios, so while we've done plenty of testing in-house, it's likely there are configurations out there we have not yet encountered.

Check out the Release Notes for a full list of My Movies features and commands. If you tried out the preliminary My Movies support in previous betas, you'll notice that this release is much more closely integrated with the My Movies GUI. Amulet no longer relies on simulated keyboard input to navigate; instead, it can jump directly to whatever part of the interface it wants.

Some of the things we'd like feedback on are:
  • Does the basic functionality of selecting Movies and TV programs by voice work okay for you?
  • Does Amulet correctly index all the items in your My Movies collection? If in doubt, check the Amulet Media Movies & TV pages; the Movies and TV Shows menus should contain all the items indexed in the My Movies database, as well as other video files found on your system. (The details view for each item has a note at the top of the description indicating if an item is from the My Movies database or elsewhere.)
  • Does Amulet correctly show the item you asked for each time (presuming it recognized your voice correctly, of course)?
  • Do you find the GUI control commands (Sort, List, View options) useful?
  • Are there other parts of the My Movies interface you use regularly which you would like to see voice controlled?
  • Does anything work differently than you might have expected?
I should take a moment to thank Brian Binnerup, the main developer of My Movies, for his help & support in getting My Movies so closely integrated with Amulet; otherwise, we would have had a much tougher time.

One thing which may be useful to know: Amulet adds a wrapper to My Movies to facilitate controlling its GUI. This wrapper is created automatically whenever you enter the My Movies interface by a voice command. If you enter My Movies via the menu strip, the wrapper is created the next time you issue a My Movies-related voice command.

Some GUI-specific voice commands, such as SHOW VIEW OPTIONS, may return to the generic My Movies gallery screen if you issue them before My Movies has been "wrapped" (though after that happens, you won't have a problem for future commands).
Last Edit: 6 years 2 months ago by eddy.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 6 years 2 months ago #511

  • sid
  • sid's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
  • Karma: 0
Just started testing it out. Works nicely so far. Looking forward to trying it out a bit more to see how fluidly it can be used.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 6 years 2 months ago #512

  • sid
  • sid's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
  • Karma: 0
Been having issues with voice control breaking in the latest update. No voice commands working at the moment. Toughts?
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 6 years 2 months ago #513

  • eddy
  • eddy's Avatar
  • OFFLINE
  • Administrator
  • Posts: 191
  • Thank you received: 2
  • Karma: 5
sid wrote:
Been having issues with voice control breaking in the latest update. No voice commands working at the moment. Toughts?
Can you do a quick bug report from the Amulet "Report a bug" menu option please? The included logfiles may highlight the cause, especially if you already have debugging enabled.

Also, when voice recognition has stopped, what do you see when you go to the main Amulet Settings status page? The area to the right of the remote picture normally indicates the current voice recognition status, so would be useful to know if it indicates everything should be working correctly.

Thanks,

Eddy
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 6 years 2 months ago #514

  • sid
  • sid's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
  • Karma: 0
Sent in a bug report. Let me know what you think.

Status page appears normal even after voice recognition has stopped.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 6 years 2 months ago #515

  • eddy
  • eddy's Avatar
  • OFFLINE
  • Administrator
  • Posts: 191
  • Thank you received: 2
  • Karma: 5
Hi Sid,

After analysing the logfiles with your bug report, this is another example of the EPG search causing the recognizer to break due to (I believe) volume of programs.

Can you let me know how much total RAM you have on your system, for reference?

Also, there is a setting in the new TV Guide page of the Amulet Settings app where you can limit the number of programs to index; can you try setting this to 5000 and see if it clears up the problem?

(Unfortunately, the type of error which is occurring is rather difficult to recover from -- it only happens when loading the EPG search grammar, but disables the entire recognition engine when it happens, including all gramamrs successuflly loaded before.)

We haven't made any significant changes to the EPG search for the 3.0 release; I suspect the reason you're seeing new issues now may simply be that the addition of the My Movies collection elements into the vocabulary may have increased the total vocabulary size beyond a tipping point for your particular system.

Let me know how you get on,

Eddy
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 6 years 2 months ago #516

  • sid
  • sid's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
  • Karma: 0
My PC has 8GB of RAM so that shouldn't be an issue. I'll try decreasing the number of programs to index.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 5 years 8 months ago #539

  • bobinyork
  • bobinyork's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Karma: 0
I have been using the Beta for a little while and can add a few comments of things that I have found!
I have noticed when using the My movies support that you can say show both Show Movies and show films and the page is listed, however if you want to select a genre and use the phrase show action movies it remains focus with My Movies,but if you say show action films it jumps to the amulet interface. Talking of which when using the amulet interface the reader says a list of films in my collection and I have to say stop reading every time, can the reader be disabled ?
Another problem I have encountered is occasionally amulet will jump to my tv guide, I do not use a built in TV card and wondered if there was a way to disable this plugin?

One last thing is when going to show TV series, It is necesary to say Show TV Series (name) This brings up the Seasons View which you can then say season 1 without the prefix Show. it would be really nice if when in TV Series focus you can say Show (name).
Keep up the great work!!
Congrats to Brian Binnerup as well. :)
Last Edit: 5 years 8 months ago by bobinyork.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 5 years 8 months ago #540

  • eddy
  • eddy's Avatar
  • OFFLINE
  • Administrator
  • Posts: 191
  • Thank you received: 2
  • Karma: 5
Hi,

Thanks for the feedback - that's very helpful!
I have noticed when using the My movies support that you can say show both Show Movies and show films and the page is listed, however if you want to select a genre and use the phrase show action movies it remains focus with My Movies, but if you say show action films it jumps to the amulet interface
We hadn't spotted this during testing -- good catch! I will ensure this is fixed for the next release.

There is currently no way to turn off the support for the Read command, though this is something that might be useful to add. It sounds like you are issuing a Show command that is being mis-recognized as a Read command? If so, and it's the same command or small set of commands, each time then you can add a Custom command with the same name, which will override the built-in command.

If you edit "C:\ProgramData\Amulet Devices\CustomCommands.txt", you can add entries like this:

Command=Read Action Movies
Action=Show Action Movies

Command=Read Comedy Movies
Action=Show Comedy Movies

which will in effect rename those two Read commands to behave like the equivalent Show command. (Unfortunately, there's no way to do a complete replace in one go, only one-at-a-time).

If items are being read to you without an explicit command being issued, it may just be that you have set the voice responses to Verbose instead of Normal under Settings / Talker; in this case, just drop it back down to Normal again and it should be less "talky".
Another problem I have encountered is occasionally amulet will jump to my tv guide, I do not use a built in TV card and wondered if there was a way to disable this plugin?
Again, if Amulet is misrecognizing a command you issue regularly as GO TO TV GUIDE or SHOW TV GUIDE, you can rename it to something else (or nothing at all) using the CustomCommand file, as described above. This is of course a workaround, rather than a fix.

It would make sense to disable the TV guide navigation capabilities when no TV support is installed, so we will look at adding this for the next release too.
One last thing is when going to show TV series, It is necesary to say Show TV Series (name) This brings up the Seasons View which you can then say season 1 without the prefix Show. it would be really nice if when in TV Series focus you can say Show (name).
We can definitely look at supporting SHOW <tvseriesname> when in the TV series view. There are some technical issues that make it a little more complicated than you might expect, but not impossible, and I agree it would be a nice feature to have.

Thanks again for the feedback - it helps us make things better for everyone!

Eddy
Last Edit: 5 years 8 months ago by eddy.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 5 years 8 months ago #541

  • bobinyork
  • bobinyork's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Karma: 0
Thanx Eddy, Work around works ok. I have been playing with the custom command file so I should have thought of that ...DOH
As far as Read command you were spot on I had talker on Verbose, so all ok now.

One last glitch that I have come across, I have several albums by Earth Wind & Fire and when showing or playing in Amulet it lists only 3 which are various collection albums with tracks from the group on it! Do you know whats going on?
Will investigate but if you know of fix please let me know.
Robert.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 5 years 8 months ago #542

  • eddy
  • eddy's Avatar
  • OFFLINE
  • Administrator
  • Posts: 191
  • Thank you received: 2
  • Karma: 5
Hi Robert,
I have several albums by Earth Wind & Fire and when showing or playing in Amulet it lists only 3 which are various collection albums with tracks from the group on it! Do you know whats going on?
Will investigate but if you know of fix please let me know.
Most likely the albums in question have inconsistent or strange MP3 tags. Amulet uses the AlbumArtist tag, if present, to identify albums by the same artist. If there is no AlbumArtist tag then it just uses the Artist tag.

So, the first step is to find the EW&F albums in Windows Explorer and turn on additional tags by right-clicking on the Explorer column headings - add Album, AlbumArtist, Authors and Contributing Artists and look for inconsistencies.

Also check what shows up if you browse to the albums in the normal Media Center music interface; this may give some clues.

If neither of these shed light, send a bug report with Media Files attached, using the Amulet Bug utility, marked for my attention, and I can take a look for any possible issues.

Regards,

Eddy
Last Edit: 5 years 8 months ago by eddy.
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 5 years 8 months ago #543

  • bobinyork
  • bobinyork's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 11
  • Karma: 0
eddy wrote:
Hi Robert,

Most likely the albums in question have inconsistent or strange MP3 tags. Amulet uses the AlbumArtist tag, if present, to identify albums by the same artist. If there is no AlbumArtist tag then it just uses the Artist tag.

Eddy

Hi Eddy, seem to have found the problem!
The tags have all got information present but on looking closely a lot of albums contain a comma...(The Best Of Earth, Wind & Fire Volume 1) This is not a problem if contained in the album title or artist title but if the comma is present in the contributing artist then amulet does not see the track, if all tracks have comma's then the album is not visible
Example the following album is visible Gilbert O'Sullivan;but not if written as Gilbert, O'Sullivan;
Regards,
Robert
The administrator has disabled public write access.

Re: My Movies support in Amulet 3.00.01 5 years 7 months ago #544

  • eddy
  • eddy's Avatar
  • OFFLINE
  • Administrator
  • Posts: 191
  • Thank you received: 2
  • Karma: 5
if the comma is present in the contributing artist then amulet does not see the track, if all tracks have comma's then the album is not visible
Example the following album is visible Gilbert O'Sullivan; but not if written as Gilbert, O'Sullivan;
I think what is happening here is that you are ending up with two artist entries for Gilbert O'Sullivan (or Earth, Wind & Fire, or whoever), one with the comma and one without. The one without is matching first when you say the artist name, and only albums that have the artist name without the command are then displayed.

A quick check would be to say the command SHOW ARTISTS, which will display a list of all recognized music artists in the song window. You can then scroll through the list and see if there are duplicate entries for any of the artists in question.

Presuming this is the case, the easiest work around is just to fix the tags on the music files to use a consistent spelling.

We may look at having Amulet be a bit less fussy when it is matching artist names - for example, treating all non-alphanumeric characters in an artist name as white space when deciding whether or not a particular track is part of an artist's repetoire. This would help for collections where there is some inconsistency in the tags.

Thanks for the investigation and follow up!

Eddy
Last Edit: 5 years 7 months ago by eddy.
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.312 seconds
Powered by Kunena Forum